Your BeatBuddy got EVEN MORE AWESOME! Firmware update 1.41

#1

Hi BeatBuddies!

We’re constantly working to improve the BeatBuddy, and we’re excited to announce our next firmware update!

Thank you all for the great feedback and suggestions. We’ve listened carefully, and we’ve implemented many of the better suggestions and are working to implement more.

Here are the new improvements:
[LIST]
[]Count-in intro: This changes the intro to a single rim shot sound per beat. So if the song is in 4/4 time, it will play 4 rim shots to count you in before the main beat starts. This is very useful when playing with other musicians, so you can all start on time! Select:Settings > Main Pedal > Intro > Count in.
[
]Disable default tempo: This will turn off the song’s default tempo, so when you are changing between songs, it will keep the tempo you set it at instead of changing to that song’s default tempo. This is very useful when you know the tempo of the song you want to play but are not sure which beat to use, so you can try many different beats quickly without having to adjust the tempo each time. Select: Settings > Main Pedal > Default Tempo > Disable.
[]Disable default drum set: This will turn off the song’s default drum set, so when you are changing between songs, it will keep the drum set you set it at instead of changing to that song’s default drum set. This is very useful when you know which drum set you would like to use (especially if you’re trying out a new drum set that you downloaded), but are not sure which beat to use, so you can try many different beats quickly without having to adjust the drum set each time. Select: Settings > Main Pedal > Default Drum Set > Disable.
[
]Press Drum Set knob to set Default Drum Set: Now you can set the default drum set of a song by holding down the drum set knob, in the same way you can set the default tempo by holding down the tempo knob.
[]Added 0% and 100% in the cue fill period: At 0%, when the pedal is press the drumfill & transition always trigger immediately. At 100% the player always wait until the next bar before launching the drumfill & transition. Default is set to 0% so that fills and transitions are always triggered immediately. To change, select: Settings > Main Pedal > Cue Period
[
]Support of External MIDI notes: Do you edit beats in other software and want to test it on the BeatBuddy without having to load it into a song? Do you have an Electronic drum set that you want to trigger better quality sound? Now if you stream MIDI notes into the BeatBuddy IN cable, the BeatBuddy will play those MIDI notes on the BeatBuddy’s ultra high quality drum sets!
[/LIST]
Bug Fixes:
[LIST]
[]When Cancelling a transition by pressing the main pedal, it was triggering an outro fill. It now cancels the transition.
[
]It was necessary to wait a beat between triggering an outro with a double tap and cancelling the outro with another tap. Now it can be done immediately. As long as the triple tap stop option is disabled (it is by default). This allows much faster cancelling the outro when you double tap by mistake.
[*]Headphones volume screen was appearing at random times when the headphones volume was turned low. This is fixed.
[/LIST]

So now you know that the new firmware is awesome. Read below carefully, how to install it on your BeatBuddy.

[B]Installing the New Firmware

  1. Download: [/B]Click Here

2. Open the file. If you can’t open the file, download free software from 7-zip.org[/URL] or [URL=‘http://www.rarlab.org/’]rarlab.org

It will look like this:

[NOTE: If you are having difficulty in installing the unzipping utility or unzipping the file with the recommended programs, here is a more comprehensive tutorial on that topic: http://mybeatbuddy.com/forum/index.php?threads/how-to-unzip-folders.1835/]

3. Connect your BeatBuddy to your computer. With the BeatBuddy powered on and the SD card inside it, connect your BeatBudy to your computer with the USB cable.

OR insert the BeatBuddy’s SD card into your computer’s SD card reader.

PLEASE NOTE: If you are using a Mac, it is better if you put the sd card in an sd card reader instead of plugging the usb cable.

4. Open the SD card folder. The computer should give you a pop-up to open the folder, or you can find the SD card drive on ‘My Computer’ (on Windows).

It will look like this:

[B]5. Drag all of the firmware files into the SD card.

Now all of the firmware files are in your SD card folder:

  1. Unplug the USB cable. Or remove the SD card from your computer and insert it into the BeatBuddy. [/B]Keep the BeatBuddy powered on. After a few moments, the screen will display ‘Updating Firmware’ and then the BeatBuddy will restart itself. DO NOT unplug the BeatBuddy’s power during this process!

After the BeatBuddy has restarted itself (shouldn’t take more than a minute), your firmware has been updated! You can confirm by going to Settings (press down both Tempo and Drum Set knobs at the same time). Then click on “About BeatBuddy”. You will see Version: FIRM-1.4.1

If for any reason you would like to load the previous version of the firmware, you can download here.

If you have any problems loading the firmware, see any glitches, or have ideas about how to improve the BeatBuddy, please comment below!

We are constantly improving the BeatBuddy and would love to hear from you.

Keep Rockin’,
David Packouz

#2

Thank for this!

The midi streaming thing is pretty bizarre from the sound of it. I’m not exactly sure how this is going to work, but it should be fun at least.
A big thanks for this device BTW. I use this everyday and it’s really a great item.

#3

I’m a little bit disappointed that the midi note limit wasn’t increased…

#4

Quoting the swede Dr Alban: Sing hallelujah!

#5

Praise Geebus!!! These are all well thought out enhancements and just in time for a long holiday weekend wooohooo! Thank you BB!!!

#6

We are working on increasing the MIDI note limit… hopefully for the next release (though no promises!).

#7

What about the MIDI clock sync slave timing problems? Nice one on the MIDI in for triggering drums though.

#8

I downloaded all the upgrades and everything loaded without any difficulty at all. The Pedal upgraded itself and I already have some of the new parameters reset. Thanks everyone for taking part in all the upgrades especially you, Mr. David Pakouz. You have outdone yourself getting all the problems and upgrades taken care of. Thank you so much. It is much appreciated. Now comes the fun!
Sincerely, Fingerstylepicker.

#9

Thanks BB team! Just great to see that you keep on innovating the BB, keep up the good work! Greatings from Dutch BB enthousiast!

#10

Great set of feature adds. Midi notes in is esp. good to have. The double tap main pedal transition to outro is still killing it for me, can’t trust my clumsy feet from making mistakes. I was hoping the comment on bug fix for outros would do it. Please add an option to disable stop from main switch and warn that it needs a second switch when used.

This is how I’m trying to use it, very simple dedicated switch use
main = start, fill(tap), transition(hold)
s1: stopped=accent s1: running=outro
s2: stopped=none s2: running=pause

#11

Just got my new Beat Buddy this morning. It worked fine with my Infinity Looper till I did the 1.4.1 update. Now my Looper won’t lock to the Beat Buddy and stutters badly.I had to reboot the Infinity to settle it down. Checked the Looper with my Boss 880 drum machine and it worked perfect.Tried old firmware 1.2.9 and it worked fine.Tried 1.4.1 and it stuttered again. Re-installed 1.2.9 and it works fine.
Why do I feel like I’m on your R&D team? Got any job openings?..“helpless in Rialto”

#12

The problem may still be the Intro length issue. I’d suggest you to disable Intros to see if this is what bugs your looper.

#13

I first heard of the Beat Buddy on Pigtronix’s Infinity video’s on their website.They said it was a perfect fit.The reason I bought it was for the Infinite pedal.Tried to tweak the intros as suggested but it did not help.

#14

Hi @P/C Geek Midi Master thanks for telling us about this problem. When you have the 1.41 firmware loaded, please check that it is: Settings > MIDI Messages > Start > Main Beat (NOT Intro). We will investigate this ASAP.

#15

I had the same issue
The fix for me was to check the ignore MIDI notes in the Global boot settings of the Infinity Looper

#16

Thank you very much Uncle Tape.Your fix was right on the money.Problem solved! For those who don’t know, use the Infinite application
to access the Midi global boot settings on the tools tab of same. Check ignore midi notes and poof, problem gone! Yay!

#17

Nice Firmware update

#18

Thank you @UncleTape – we’ll update the firmware to make the default setting MIDI notes off so others don’t have this problem, with an option to turn it on.

#19

One more about new firmware: do I observe correctly that upgrading to 1.41 default value for cue fill period is changed to 100% (unlike 75% previously)? If your fills now start differently, set it back to 75%

#20

Infinity looper was having a fit. The fix posted a few posts above works, so anyone else, do this

thanks.