2.17 horrible clipping sound

I recently bought an Aeros, and honestly after a few minutes with the last official update (2.13) I was about to return it immediately, because of the unusable freeform mode, of audio clipping and others…

Then I discovered this forum, and found my way to the 2.17 firmware, and it clearly brings a lot. Freeform is now at least correct, and I felt so excited that I didn’t immediately realize that the “audio pops issue” was far from being fixed !

Nevertheless how is it possible possible that such high-end device cannot achieve something so basic a device costing less than 100 bucks can easily do ??

The so-called crossfade mechanism supposed to fix audio pops simply doesn’t work !! I reproduce this almost all the time, and it renders the whole thing completely useless !

I don’t even want to enter the discussion is it my usage or whatever, so I uploaded a video to really show how it sounds like… No comment (don’t expect a song, with changes in sound volume or dynamics it’s just a simple repeated chord).

Honestly, I didn’t know when I bought that it was a kickstarter campaign… I expected something at least reasonably working, and currently this is far from being acceptable.

Here under the changelog for the 2.17, mentioning the cross fade feature:

@DavidPackouz, @BrennanSingularSound, time is running, and I have 30 days to return it to my retailer.

I had great expectations with this product, but if things are not even fixed when you claim they are, then it becomes a real issue…

You have to do something, and you have to do it now.


@LaurentB we’re looking into this right now

@LaurentB does this happen every time or only occasionally? Only with freeform mode or also with quantized?

We’re testing this on our units and can’t seem to replicate your issue, so we’re trying to figure it out.

Also – in the video it seems like the pop happened before you even pressed the button. Is that the case or is the audio and video not matched up?

Can you check your input audio levels? Could that pop have been caused by clipping?

Are you recording in mono? we noticed a bug that caused the signal level to be increased in this mode. We fixed this.

I don’t use the quantized mode, I can check tomorrow morning. It’s a bit late in my timezone to perform sound tests rights now.

Actually I think the dropbox online js player somehow degrades audio/video quality. I cannot hear that on the original video. But the real problem is the one you can hear starting at 0:15.

For me audio level are good, I do two strums at the beginning of the video to show the vu-meter. And also you can see that sound-wave doesn’t look like oversized…

I record in stereo (you may notice that from the vu- meter too) straight out of my Kemper outputting directly to my DAW. I am very used to do recording, and my levels, setup and everything around should be ok…

1 Like

Not all the time, if the end of the loop corresponds to a fading waveform there is no problem. But there should be no particular use-case… No matters how a loop ends, it should transition smoothly to how it started. When I say transition I mean link (as it should not introduce any gap) the end of the waveform to its beginning.

Actually I didn’t notice immediately, and usually I do not record the output of the looper, as if I need a recorded loop, I do that directly within my DAW, but I was performing some tests, and did record the output of the Aeros. This is how actually I noticed the issue, and once I started noticing it, it became the only thing I could hear.
Tomorrow I will more extensively perform tests with various levels and type of
sounds (from clear to bluesy and then metal…)

1 Like

@LaurentB thank you very much for looking into this. And I apologize for the frusteration. I completely agree that a popping sound completely ruins an otherwise amazing product. So we are determined to fix this.

I just posted a new firmware version 2.17.5 – please use this version to test.

Thank you!

1 Like

@DavidPackouz Just performed a quick test with the new 2.17.5 firmware. The problem is still there.

Although I performed it with a very different setup.

The problem has been initially reported with the following setup:

PRS Custom24 -> Kemper -> stereo line out -> Aeros(line-in stereo / stereo out) -> ZoomLiveTrak12 Mixing Deck -> DAW(Ardour) -> Monitoring Speakers

This is my standard setup for recording, that I use every day, except for the introduction of Aeros in the middle of the chain.

Now I just tested with my quick’n dirty gear:

Squier strat -> Aeros (instrument mono in / mono out) -> IDCore Beam -> my ears :wink:

This is my setup to noodle in front of TV, and normally I do not play loud at all, but unfortunately when I tried to push a bit the volume or use a headset, I can clearly hear the same problem.

So for the purpose of the test, I just replaced the Aeros with my good old Boss RC2, played exactly the same thing, it’s clearly perfect, not a glitch… even with a headset.

Forgot to mention that the test I did with the Boss RC2 was with the second gear setup. Regarding the first gear set, I had already performed a comparative test with the Kemper internal looper (which is pretty limited in terms of duration or has no multiparts, but does very well what it does…looping) which I didn’t initially report, and as usual it worked flawlessly too.

I only indicated what my gear and setup was for you to review my Aeros setup in terms of line-in vs instrument-in, and mono vs stereo (in and out), but I don’t think I am wrong. Please do not hesitate to correct me if you feel I am.

My PRS pickups output is obviously far more powerful than what exits from the Squier’s, but as the problem exists with the Squier too…

1 Like

I’m getting clipping too on beta, will check I have the latest version.

Last tests I mentioned are with the latest firmware.

Any news ?

@LaurentB please test this version 2.17.6

Hello @DavidPackouz,
Install in progress… I see no changelog, am I alpha tester :stuck_out_tongue_winking_eye: ?

Sorry to insist, but it would be nice, if you could take the habit to provide a file hash (I suggested in the 2.17.x firmware page a SHA512, which is the current standard, but actually pick the one you prefer) when you release a new version… I like to flash my devices with stuff I’m sure I got the right content for… Thank you in advance.

@LaurentB we made this version with just the fix for the popping issue. We plan to make a new version with the changlog updated once you confirm the problem has been solved.

1 Like

Install in progress of firmware 2.17.6

$ sha512sum aeros-2.17.6.bin 
fe3619f9a810e9d6e37e49d86c6e3b590bade622e91e3ea194137c94de7dace70ae18b4b7852f8768314779cd2c88921c59058ba93ec9d61d328b1070265a26b  aeros-2.17.6.bin

@LaurentB regarding the hash issue, the update file is internally encrypted so it’s not possible for someone to change the content and create a valid update

@DavidPackouz Hashes have multiple purposes, and my concern here is not that someone would temper the file you release but the fact that I want to be sure that what I copy to the SD card is correct. It’s a common and sane practice used almost everywhere in software development/releasing whatever the type of packaging used… and which would cost you absolutely nothing.

Ok, I won’t keep the suspense too long. It seems it’s a success !! :+1: I can’t hear the pops anymore !
I will conduct further testing with different levels, so still to be confirmed. But for the time being I feel pretty confident it solves the issue. You may deserve a :beers:

@LaurentB fantastic!!! Very happy to hear the pops are gone :smiley: let me know if you see any other problems.

We always name the firmware file with the firmware version… doesn’t that solve the issue?


I’m testing intensively, but can’t reproduce anymore! Looks like my brand new roadster got finally its wheels !! Congrats !

Nope… Hashes are there to prevent any mistake you may do (i.e. providing the wrong file, think twice before saying that in urgency it could not happen) bad things that could happen in between like hacking, even if unlikely in this case, (you’re saying it’s not possible, but you are not open source, no one can verify that you’re doing things correctly, that you are not using an outdated encryption algorithm, that you are using it correctly…yes don’t laugh :wink: ), and any mistake I could do on my side (i.e. renaming the wrong file or other…).
It’s the security belt anyone releasing a piece of software needs…

1 Like

Bug marked as #fixed