Aeros audio pop sound issue (makes it unusable for ambient music)

I’ve always had this issue with the Aeros: when I try to make ambient music and have a seamless soundscape loop, I always get a ‘‘pop’’ at the beginning of the loop.

Here’s a link to it demonstrated in a video:

It doesn’t even work when I record an empty loop and then add the soundscape as an overdub. The pop is still there every time. Like there is no crossfade at all.

I upgraded to 5.1.1 using my SD Card, because I read somewhere that it would solve this issue, but it did not for me.

Even in the rare instance that I get a ‘‘seamless-ish’’ loop, each time that I stop and restart the loop, or lower and raise the volume, the pop comes right back.

It’s a big deal breaker to play ambient music. I teach how to play ambient guitar on my channel and many of my students already bought the Aeros from my recommandation. I’ve never had this problem with any other looper I’ve tried. I had to use a different looper to make my tutorial video this morning because the ‘‘pop’’ sound was too annoying.

If it doesn’t get fixed soon, I’ll have to use another looper in my trainings. That would be sad considering how good the Aeros is at about everything else but this basic thing :slight_smile:

1 Like

Just curious. Have you loaded the audio file onto your PC and can you tell where the pop starts. Perhaps it’s a button noise issue. (moved to silent switches on the gold version)
If you have a MIDI controller you could try and issue a start recording command via MIDI and see if that corrects the issue.
FYI…I don’t get the popping noise…

Thank you for your answer. It’s very hard to tell on the audio file where the pop starts. I don’t see it.

I know I’m not the only one to have had this issue while playing ambient style music from reading another thread. There were several people having the same pop with a soundscape, but they said this was solved with the new 5.1.1 update, and that update didn’t do it for me, so that’s why I restarted the conversation.

The button noise issue is possible, but I’m not sure about this, since I once was able to get a seamless loop, but the pop appeared when I stopped the song and restarted it again. Very weird.

If you don’t see the “pop” on the audio file then it certainly sounds like an internal software or hardware issue. I would try recording at higher or lower input levels and see if it makes a difference.
If you load a file to your card with your PC (backing track) does it do the same thing?

Love your work, Antoine. Sorry to hear that you experience this. I have not noticed this, but I play mostly rythmic music. Moving towards ambient, though, so lets hope the guys at Singular Sound chime in.

I also am an ambient/soundscape musician, and I have not experienced this problem with pops. I can only guess that it has something to do with the pedalboard setup itself, or your particular unit. I regularly do 6 tracks with overdubs and never get a pop or click. The Aeros is the last in the chain, with 11 pedals before it in series plus a send/return to a tape delay.
Have you tried the unit on its own to see if it behaves?

1 Like

A post was split to a new topic: Pop on 5.1.1

Hey there,

Thanks for reaching out there definitely is something there in your video but without steps to reproduce we won’t be able to diagnose any issue. As you have seen others are not experiencing this issue and so there has to be a particularity to your setup or the steps you follow to get the audio recorded.

There isn’t much we can do until we have enough information to make the pop happen on our end as well

Please let us know all the steps you take to reproduce this issue and the specifics of your setup so we can look further into it.

Thanks for reporting!

Feel free to post this here or to forward that all to, thanks

Sorry for the delay Brennan.

I made another video to explain and make an update.

I now use the Gold Edition, but I get the same problem, so the problem wasn’t the footswitches.

I’m not using MIDI or anything. The Aeros is last on my pedalboard and I play a 100% wet reverb before it to make the ambient drone. Then, the best I can do when I record it is to get a seamless result at once, but as soon as I stop and start the loop, the pop goes right back in at the beginning of every cycle.

And that’s when I succeed to pull off a seamless loop, because most of the times, the pop is added right as I close a loop.

NOTE: I’m on 5.1.1, but that also happened in previous versions like 5.0.3.

Thank you for taking a look at this.


1 Like

Hi Antoine
You are not the only one. I report this issue too
I’m not a Ambient player, I get a pop when I close the loop, the same sound that you have
Sometimes this pop is recorded with the loop , sometimes I have the pop when closing but not recorded
I get the pop on a basic bass line .
But difficult for me to reproduce

I see that you can reproduce it. That can be helpfull for SS.

Thank you so much for the video it’s very useful to us. I have one last pertinent question here were you ever using 4.3.1, did it ever not happen?

Let me know, thanks!

I’m a fairly new user, so I didn’t play through a lot of versions, but as far as I know, it has always happened, even on version 4 (even though v.5 was released very soon after I started using it).

Also, another detail is that, in the rare instance where I’m able to get a seamless result with my ambient drone without a pop, it’s not only stopping and restarting the song that introduces the pop, but also playing with the master volume. Lowering it and raising it also adds a pop, even though it wasn’t there at first. Very weird.

Ok, thank you for the info, we are investigating

However, I am wondering if a workaround to solving your issue without SW intervention is to set the Track Button Mode (Device settings > Behavior settings) to ROP mode

This will require one more tap to stop recording, but will allow you to have more time to let your playing fade a bit before closing the loop

Does this work at all to improve your experience? We did make the ROP mode specifically for ambient loopers like yourself. It just initiates an overdub instead of playing back only, allowing you to capture reverb tails without an awkward cutoff.

Let me know thanks!

Thank you for the idea.

I just tried that and I still get that nasty pop (even though I took time to let the ambient drone fade through the ROP mode before stopping the overdub). And the pop gets worse whenever I stop the song and restart it again like shown in my second update video.

It’s like everytime the loop repeats, it adds a pop. I have not found a way not to get that pop so far. I have never experienced this with any other looper I’ve tried in the past.

Where is the pop occurring at the loop seam or where you closed the overdub?

It’s always at the loop seam. You physically see the vertical line on screen, that’s where the pop is always occuring. It has never happened that I got a pop anywhere else than at the loop seam. Thanks

1 Like

Thank you for the info we will continue to look into it, we thank you for your patience!

1 Like

Hi Everybody,
I’ve been struggling with this same problem.

This is the Video I sent to the tech support via the e-mail.
I was asked to send another video with exact specifics and haven’t had time to do that.

This was recorded with no chain, Just a Roland Juno DS61 Keyboard with a PAD, in free mode.
I have had no success trying to get a seamless loop without a POP… Unfortauntely this is a dealbreaker for me as well as this is the main feature of the music I make when using other Loopers like the Boss Rc505/600, Ableton Live. Line 6 Delay.

I really hope the guys at SS can figure this one out.
It’s been a month since I’ve had my Aeros Gold, and being a new user,
I’ve not been able to use it to make music as there was the over dub errors not recording back properly in the last firmware version. I see that is corrected in 5.1.1 which is a relief.

Do I need to make a more specific video than this? Or is t hat easily recreatable.
Eg. do I need to list all my settings?
To infer that when you try this on your machine (tech) it does not behave this way?

Thanks so much,