BB white screen - reads SD but won't load it

I have only had my BB for about a week. Tonight I went to power it up and got a white screen. I have gone through multiple threads and done exhaustive troubleshooting and nothing. I’ve created a new ISO on a new card, tried re-upgrading the firmware, swearing, nothing works. If I plug the BB in via USB my Mac recognizes it. I can access the card via BB manager, the BB just doesn’t seem to be accessing the card. Any further ideas? At this point it seems my only option is to reach out for a replacement.

Thank you.


Hello, when it is open , try to take out the card and put it again.

I’ve tried that multiple times with both the original and the backup card. Unfortunately nothing has worked.

  1. Put the SD card in your computer slot reader; open the card in the Finder, take a screen shot of the the SD card.
  2. Now with the SD card still selected, press CMD-I (Get Info) and take another screen shot.
  3. Post both screen shots in reply to this post.

Greetings Persist,

Per your request, here are the screen shots requested.

Thanks. The screen shots are helpful. Here’s what I believe is the issue. You have some files and folders that don’t belong on the SD card and the firmware may not have loaded correctly. Here’s what the card contents should look like:

Here’s the steps I’d take. Follow these steps one at a time until pedal’s back to normal.

  • With the SD card in your Mac slot reader, use the Finder to delete all files on your card and empty the trash (DO NOT use Disk Utility to Erase your card)
  • Download and unzip a fresh copy of the firmware
  • Drag the firmware files to your unlocked (make sure it’s unlocked) SD card
  • Eject the card from your computer
  • With the power off on your BeatBuddy (BB), insert the SD card and power the pedal up
  • Allow it to update
    Does the display and pedal appear to work? If so, follow step 2. If not, follow step 3.
    STEP 2:
  • Power the pedal down and remove the SD card
  • Insert card in your computer
  • BeatBuddy Manager (BBM) File > Export > Project to SD card
  • Accept prompt for future synchronization
  • Eject SD card from computer
  • Power still off on pedal, insert SD card and power back up
  • Does it load songs and do they play? If so, you should be good to go. If not, follow step 3
    STEP 3:
  • Open and follow my instructions from this link General Disaster Recovery
  • If this still doesn’t work you can try a new SD card (out of the wrapper, it’s already correctly formatted)
  • If still not working, contact Support, for assistance

Still nothing but a blank white screen. I deleted the files, copied the firmware over, put the card in and powered up the BB and it just sits there glowing. Even tried it with the backup SD card I created while troubleshooting originally.

Sorry to hear you can’t get it working. I know it’s gotta be frustrating.
Does your SD card contents appear similar to the contents from my screen shot? If it still appears like your posted screen shot, it could be that your SD card is locked.

Verify that you are still using the correct power adaptor for the pedal. Make sure no cables but the power cable is plugged into your BB pedal.

If you want to try something a little more drastic, you can try the instructions at Pedal does not power on. This solution usually solves problems with a bricked pedal (which yours is obviously not) but it’s about the only thing I can think of that we haven’t tried.

Certainly understandable if you’d prefer to get in touch with Support,

Let us know how it turns out.

The card is definitely unlocked because I can write to it. I am using the original power cord and nothing else is plugged in except for power. I’ve even gone around the house trying different outlets! Argghhhh! I will take a look at the other link provided. It’s weird because it worked a couple of days ago and all I did was plug it in. There have been no power spikes, no storms, nothing at all. It also doesn’t even give me the “No SD card inserted” error when I take the card out and power it on. I’ve already shot an e-mail off to support.

Thank you for all of your help. I’m a glutton for punishment so i’ll probably sit here and fiddle around with it for a bit longer (instead of just letting it go and practicing).

Sounding more and more like a hardware problem. When you hear from Support, share a link to this thread with him so he can see what steps you’ve used for troubleshooting.

I will! Again, thank you for your help.

Did you ever get it sorted? I am having the same issue

Did you follow all of the steps in post 6/12 (above)? If so and you still cannot get it working, please contact Support, and let us know the outcome.