Aeros Firmware 4.2.x



Same is happening for me. Tried numerous times. Am close to router.

Ran diagnostics. Download from sigul

Cur 10338 kb/s.
Avg 5242 kb/s

The splash screen will suddenly appear after Downloading update progress bar appears and incrementalally updates for a bit. I’ve seen it get to 56% and then splash screen. Also seen it show splash screen around 30%

It fails at random % every time. I’ve tried a dozen times at least

Tried with and without sd card

FINALLY SUCCESS. Took about 20 tries.

I gave up after about 10 times failing via wifi and got it to update firmware using sd card.
Just ran wifi diagnostic too and didn’t get any error message.
Have shared a screenshot of this with support.

Seems as though this is likely related to wifi hardware on the Aeros. Wonder if we should be replacing the unit to address this…waiting to hear back from support, but any thoughts welcome.

Is there a CC to lock a track?
I couldn’t find a command in the list.
I’d like to lock a track hands free while in the middle of a song.

No there is not
but you can lock it to go on the mixer page of the Aeros (hold left switch)
select the track to lock
press and hold the left switch you will see “lock” and than press and hold again to lock the track

I know it can be done in the aeros.
But a CC is missing to do it handsfree with MM in the middle of a song IMHO.

You can only lock a track prior to starting the recording process. It would be nice to do it mid stream like last down a guitar track then create a percussive track around that which would carry on for that and other tracks.

Just noticed I should’ve posted my 4.2.4 issue in here:

Maybe the admins can move my post for I see other people suffering from the infamous ‘‘pre-count’’ even though pre-roll is set to zero…

Found a way to fix it!
Instead of sending the clock from Ableton to the Headrush and to the Aeros I’ve switched it around so that the Ableton clock goes to the Aeros and thru to the Headrush…

Turns out enabling ‘‘midi start - PLAYBACK’’ on the Aeros fixed the delay problem and really helps the Headrush to get good clock too.

Hope this can help anyone else with the same issue.

UPDATE, there is a new bug now…the recording starts at the right spot but when I’m done recording after the I hit the recording button again to initiate playback (I have it set to RPO)…the first bar of the loop is missing the first time around…BUT it is there the second time around…

Any Ideas before I go back to 3.4.2?

Sorry! Hit reply early:

Hello, thank you for reporting we have been looking into it and have found some possible issues and are working on it.

This is likely not an issue with your physical Aeros, it seems it could be something else. We will get back to you.

The best thing to do when this happens is to (if an SD is plugged in) grab the .log files that are created in your SD and send those to along with an explanation of what is going on. A video/photos are useful also! Support can guide you through any tests they may ask you to diagnose the issue.

I do suggest you reach out to support, as they can guide you through a process that may fix the issue(s) reported, but requires “flashing” the Aeros which is a total Factory Reset.

Thank you again for reporting and please do reach out to support at your earliest convenience!

This is planned to be done, it is not currently supported via MIDI

Thanks for the question!

Thank you for your reporting, if you can, please send videos and an explanation of what is happening to me via DM, I would like to know more about your setup to help replicate and reproduce the bug. First thing I would check is if the Tempo matching fully and if MIDI Sync status on the Loop Studio stopped screen reads ON.

If we can reproduce it we can fix it easily, so we always need a lot of information to help out, videos are also greatly appreciated as they clarify a lot and help us catch details that may not have been brought up.

You can find more info on bug reports here.

I will reply on your thread to follow up on that, thanks!

Hi Brennan,
Thanks for your response.

I have reached out to support and had several back-and-forths via email over the last couple weeks, but this is the first I’m hearing about:


Should I reach back out to them and reference your quotes, above, or just wait to hear back from them?

Thanks very much for the info,

You should get back about the flashing of Aeros, it may be beneficial to do this and possibly fix the issue.

I have notified support of the issue

Thanks for the question!

I find the MIDI-based tempo on the Aeros (using BeatBuddy as the master) has been a lot less reliable over the last few versions. In my setup the Aeros BPM will vary by +/- 2-3 BPM while stopped, then
“lock in” to whatever the final tempo is when you actually start a recording. This seems less than ideal.

I’ve also had issues with using a “pre-recorded” Aeros part and starting it mid-song relative to the BeatBuddy when the song is in non-4/4. That is, I’ve got a pre-recorded part in 6/8, Aeros and BeatBuddy are in 6/8, Aeros is set to NOT play automatically on BeatBuddy start but I want to hit play on the Aeros mid-song while the BeatBuddy is going. Under these conditions, it’s unreliable as to which measure the Aeros part will start to play. Sometimes it’s the next measure, other times it takes an extra measure or two. Thoughts?

Is there any way via midi commands to delete Parts?

or perhaps a “delete everything that isn’t locked”?

I’m doing two songs back to back where I lock track 1 in part 1,then record a verse/chorus/bridge.

the rhythm that I locked on track one is the exact rhythm that I need for the next song. So rather than deleting the whole song, and rebuilding my rhythm track, I’ve been cycling through 4 song parts and deleting the tracks, to try and make it “seamless” but its not really particularly effective. takes a long time. all of the deleting I’m doing using the actual aeros buttons since as far as I’m aware, theres no delete track/part midi commands.

I’m wondering if I’ve missed something. Is there anything someone could suggest,or is there an updated complete list of midi commands available?all I can find is the 2019 list, and then the things added on each update.

1 Like

Hi, could you please forward a video to so we can look into this. Please include some more information like the units you are using in your set up and how they are connected, thanks!

This seems like this issue:

Please review this issue and let me know if this is the bug you are describing, if it is, you could try to see if the issue is fixed for you in the 4.3.x beta which is already up!

Let me know, thanks!

This is not yet possible but may be at some point we do have more MIDI we’d like to add in the future, currently the last part can be deleted using the touchscreen, simply tap the last part’s icon and confirm deletion once the pop up appears.

The complete command list is on google docs and is in the manual.

I’m using the online wifi onboard update from 3.5
It downloads around 30% and then reboots, but stays in reboot for 30mins now :frowning:

Hi, I wrote to you elsewhere but please write to, thanks