Aeros Firmware 4.3.x

Hi there fellow Aerosnaughts!

I’m excited to post Aeros firmware version 4.3.0! This is a beta version for testing purposes - we tested it extensively and there is one know issue (listed below). Please comment

Version 4.3.0 Changelog:

  • Added Auto Decay setting: Lower the volume of previous audio layers with each additional overdub layer
  • Added Clipping indicator: When audio input clips, the input meter will appear for 3 seconds
  • Added Expression pedal volume control and calibration in diagnostics screen
  • Added German language

Bug Fixes:

  • Song select MIDI Messages now work on the home screen
  • Scroll wheel now scrolls through pop up text
  • While Aeros is stopped receiving MIDI CC 113 will change the part without starting playback

Known Issue

  • Using the erase all content feature found in the settings screen causes a crash. This will be fixed in the next version.

To try out this firmware , update with the SD card (note: the SD card must be between 4-32 GB in capacity): Download this file , rename the downloaded file (currently named aeros-4.3.0.bin) to aeros.bin and then place it on an SD card and into your Aeros before turning it on.

IMPORTANT: Turn off your Aeros BEFORE putting in the SD card. Putting in the SD card while Aeros is on and then immediately turning it off can corrupt the firmware file.

If you see any bugs , please report it to us so we can fix it! Please send logs to support@singularsound.com along with a video and/or a description of the bug. To learn more about useful information you could give us to better help you, please read this post on bug reports.

To go back to the previous official firmware, use the same SD card update method to install the last official version 4.2.4

3 Likes

I’m excited to test that
Thank you

2 Likes

Hello I test it right now

  • I’m very happy to see the level input when recording. GREAT.

About the loop decay
-Nice, but wierd to use when using the undo/redo . Nice

-About the expression pedal
What kind of pedal works? stereo or mono jack? I try a mono expression pedal . Is indicate that a pedal is connected with min and max. can you explain what to do ? because nothing is moving
I’m not a huge fan of this , but was to try it

Song select on home screen? Where?

Cheers

The expression pedal must be connected using a TRS cable, it is only meant to control the main output volume for the loop playback. It is only usable in the Loop Studio screen.

1 Like

The decay mode is not working properly
Sometimes when it’s OFF it’s still working, and I need to restart the looper because it drop down the volume like the way I set it up on the settings with the Auto Decay OFF
Sometimes when it’s ON it don’t work, but sometimes well

OK I have it
When you start a new song and select the Loop Decay and the rate , than it’s Ok ,it works let we suppose the rate is on 80
If you erase the song and adjust the rate of this same song to 30; It doenst work on 30
Now if you make a new song and set the rate on 3O, this gonna work on 80, it’s like it keep in memory the rate of the previous song
When you set the Loop Decay OFF, it’s still working like the previous song,
Than you need to restart the looper . to make it working correctly

Thank you for reporting and the details! We will look into it!

1 Like

A video is sending to the support too

Greetings all! New Aeros person here. I was excited to see the loop decay option in the beta, as I use loop aging/decay heavily with my Ditto X4. I’ve been trying it out and am noticing that the decay only seems to work if I switch from overdub to play and then back to overdub. If I leave overdub activated through several layers, no decay occurs.

It’s not the behavior I would have expected from the feature. All the other looper I have with loop decay automatically fade the loop as each layer is added to the overdub.

Thanks!!!

Hi
Maybe stupid question, but:
Do you set the loop decay ON in the settings?
Do you adjust your rate? how much is your rate?

Yep - if you don’t set loop decay to ON, you don’t get any decay.

I have tried several different rates - from 20% to 90%.

Hello there,

This is part of how the Aeros works when an overdub is left on over the loop indefinitely. The Aeros never runs out of space when doing this because the same file is being recorded and merged to over and over, meaning the autodecay is not being enacted since it only enacts when new layers are created.

Thanks for the question!

Thanks for clarifying that is expected behavior with this implementation. I have to say that I find it a bit disappointing as it limits the Aeros’ use for ever evolving ambient soundscape looping, which is what I do. As I mentioned, the Ditto X4 has a better implementation for this use case, as does the Infinity loopers and the Line 6 Helix loopers to name a few. Maybe that could be put on the backlog for future consideration?

You are free to request it in the appropriate place and we may look into it, to learn more about how we tag feature requests, read here!

Okay, maybe I’m doing someting wrong, but after my recording I safe the file.
the next time, I open it, the volume is increased. I take a old record and it’s okay….then I go back….and the record again is increased. The sound is horrible and the wave is a thick fat line.
I went back to the previous version and everything is okay.
I hope you understand me and maybe have a solution.
Thank’s

1 Like

I sent a video to Jay at support. Same with me! Super annoying and about blew my ears out since I practice with in ears. I went back to 4.2.4 and all is well.

Thank you very much for reporting this. I now know it’s not my fault And I’m not the only one.

1 Like