My beat buddy won’t turn on!

After being away for about a year I decided to get my beat buddy back from the closet and use it today! For my surprise it won’t turn on?? Don’t know what to do ! Please help me!


Cannot find the link!!!

Click on the text in blue font.

So I tried updating it but it got stuck on a white screen for a good while so my dad unplugged it. After that it wouldn’t turn on at all. I tried pasting the back up content folders into it from this link Software Download | Premium Library for BeatBuddy and turning it back on. Didn’t work. Then I formatted the SD card and put the files back in, didn’t work.

So I unplugged the device mid update and then formatted the SD card. Any help?

Ok I so it didn’t specify what firmware version to copy and paste so I pasted the 3.60 version onto the SD card and then put it into the BeatBuddy but it still wont turn on, should I put in the backup content files in aswell? but that wasnt shown in the video. (im on windows)

Click on the link to view the full set of instructions for Windows and follow them all the way to completion.

Yes I followed it til step 3, and the part where he randomly pastes firmware files, I pasted the version 3.6 files and put the card into my BeatBuddy but no luck. Ill again from the beginning

It’s not working. Does it matter that my SD card is showing 2GB instead of 4 GB

Should not matter. The source image is 2Gb and that’s why your SD card shows 2Gb. Imagine doing that to a 32Gb card :grimacing: The good news is that once you get everything working again (which you will), the card can be repartitioned to 4Gb.

Sorry to hear that it did not work. Time to contact Support, for the next steps.

its been an entire day, they dont seem to be replying, I have a concert tomorrow so it’s pretty urgent. Is there anyway I could download the 1.85 firmware? I cant find it

Support usually handles e-mail in the order they’re received.

My opinion is that a different firmware version will most likely not work on a bricked pedal. Meanwhile, here’s some thoughts if you’d care to try:

  • Make sure you’re not using an SD card larger than 32Gb
  • Card is not locked
  • Card is formatted as MS DOS 32-bit
  • Use the power adapter that came with the pedal and that the jack is firmly seated
  • Power the pedal off when inserting or removing card
  • Try the recovery process one more time following the instructions exactly

Support may be able to help via phone or a remote session but given your location (if other than the U.S.) that might not be feasible.

1 Like

Thank you for all the help, I went out and bought a new SD card and followed the steps again and it finally turned on. So in the end it was a problem with the SD card. It works just fine now. Thanks again, I appreciate all the help.

1 Like

Glad to hear you got it working. Have a good show.

I need instructions for windows. the link is for Mac …

The link has instructions for Windows (and macOS).