Everlong DOP, OPB 2018-05-28 - Foo Fighters

Requires:

  • v1 Rock 1.1
  • v2 NP Standard Pro Bass
  • Beta BeatBuddy Manager version ≥1.6b
  • Firmware ≥ v2.0.4
Includes: 2 songs, MIDI source file and Chords & Lyrics

Download Here