New BeatBuddy Firmware (3.6.0 "The Bug Zapper")

Hi Everybody!

I’m happy to announce a new version of the BeatBuddy firmware.

This new update is mainly a stability improvement. We found a few bugs and fixed them. The details are below:

New BeatBuddy Firmware (3.6.0 “The Bug Zapper”)

  • Fixed count-in color style and behavior
  • Fixed Headphone volume random display
  • Fixed Missing Audio bug – this was a bug that cause certain drum sounds not to be played in rare cases.
  • Stability improvement to memory management (That were done while looking for the memory corruption problem in the missing audio bug)
  • Midi Time signature – added check to make sure the values sent are valid, to prevent errors in MIDI files causing errors in the MIDI sync
  • Prevent default song tempo / drumset if those were set by MIDI 500ms before – so if you choose a song with certain settings through MIDI, the BB won’t overide those settings.

As always, if you find any bugs or have ideas for improving the BeatBuddy, please email us at

Download BeatBuddy Firmware 3.6.0 here!


Done Thanks…

1 Like

So the “Won’t pass CC102 (Next Part) commands when in MIDI MERGE Mode” bug is not yet zapped?

So I’m anxious to learn how many users have actually installed this latest “upgrade” and were there problems like last one. The hassle I experienced from last one has left me unwilling to install until a large group of users have installed without experiencing major problems. Thanks

We’ve been testing this version for about a month with about 15 users and have not seen anything concerning. If you see anything, let us know! You can also always go back to older firmware versions with the same update process.

1 Like

Sorry, it is not. But it is at the TOP of the bug list to be zapped for the next release.

1 Like

Thanks. Download and update was a breeze with no issues.

1 Like

Still running just fine on 2.4 for what I need. I will be watching this thread though. I like the idea of the tempo update from the 2.7 and new look in 3.2 but I am not willing to risk losing what I have now that is working just fine at the moment.

Hope to keep seeing positive feedback from this update for a while before I take the plunge.


1 Like

This is on my “To-Do” list. The last few weeks have been extremely busy. I am not sure when I can get to it. Will keep this post updated when I get a good 2 hours to sit back update and then test out all all the functions I frequently use. :grinning::+1:

1 Like

Will the MIDI tempo bug be zapped soon?.
The one described in the previous update:

Known Bugs

  • Using MIDI commands to change the tempo results in the new tap tempo screen staying on indefinitely. You should be able to clear the screen by starting a song if this happens to you. Our developer is working on a fix.

@mcanoreagan This should have been fixed in this update. Do you still see this bug?

From what I can see, the BB is passing the CC102, it’s just not on the midi channel specified rather the CC102 get sent in channel 1.

I have a Ditto X4 on channel 4 (can’t change this) and starts, stops all get sent on channel 4 but the CC102 gets sent on channel 1.

Ditto X4 doesn’t understand the CC102, so I run midi out of the Beatbuddy into the computer where I can intercept the midi comming out of the BB and pass the right things along to the X4.

Yes, I definitely still see it. Do you think I should try reapplying the update? Thanks.

Yes, try reapplying the update, and check in the “About BeatBuddy” section of the settings to make sure it says version 3.60. If it’s still happening, please take a short video and send it to me. Thanks!

Hi! Update was reapplied and it worked. The tap tempo screen still shows up when it receives the external signal but it disappears after a few seconds. Thanks!!

hey guys. I can’t download this firmware file. can you help me with that?

Link appears to be down on the Main Singular page. @AnthonySostre - Can we get this fixed?

1 Like


Both links to Firmware update (3.0.2 and 3.0.6) doesn’t work.
Please fix

1 Like

Please stop lying: links to update firmware doesn’t work.

1 Like