Maestro: inconsistent response on Aeros

I’m wondering if anyone else has this problem with either the original MIDI Maestro or the Gold version (I’ve had this problem with both):

This has really been bugging me. I have the MM controlling the Aeros Loop Station and maybe one out of 20 times, pressing one of the MM buttons does nothing. Second try works (but then it’s too late). I can’t tell if it’s a subtle difference in the angle of my foot at the time or if it’s just a completely random occurrence. I’m definitely pressing the switch all the way down, so all I can think of is the angle of my foot (unless it has nothing to do with how I’m pressing the button).

Am I the only one?

  • Slim
1 Like

Sounds like some mechanical issue, perhaps some dirt inside the MM? Or some loose connection somewhere. I don’t recall having such issues with my MM :thinking:

If it happens 1/20 with all the six buttons then it’s you, but if each button has different probability then it’s the MM you have :neutral_face:

Edit: Ah, didn’t notice that you encountered it with new and old model. Then it’s definitely you :no_mouth: But I’ll keep this in mind if I encounter this myself → and notify you in this thread :relieved:

I don’t think it’s the particular MM, as this is my second one, both units (regular and gold) showed this issue within the first week of use (brand new units). If it’s me, I don’t know what I could be doing wrong – full press of the button.

Now that I think, I might have encountered similar issue with the BB (the pedal on BB, not via MIDI). But luckily it’s not so time critical :relieved:

That being said, perhaps it’s just a quality issue :thinking:

Note: since the effect is seen through the Aeros, it could be anything in the signal path, including Aeros itself :no_mouth: So the MM, MIDI cable(s), any units in-between, Aeros itself. Since two MM’s show same symptoms it points out to the other components :thinking: Have you tried swapping them to verify that they are not the cause instead of MM? :upside_down_face:

P.S. Does it matter if you press fast or slow?

I’ve swapped cables, the only thing I haven’t swapped is the Aeros itself (I only have the one). I think it may only happen on a fast press. I’ve never gotten it to happen on a slow press. So, that could be it, but that seems like very strange behavior. I’ll experiment more tomorrow with this in mind – thanks for the suggestion!

1 Like

To me that’s not strange at all that fast pressing might be ignored by MM. I know that every button needs some filtering because a single press is actually multiple presses from the electronics/physics point of view.

Okay, but what I just said was how multiple electrical signals are interpreted as one signal. But how can we miss these signals/signal altogether?

The answer is that we don’t want every single rogue electron to be interpreted as button press, right? So there needs to be a continuous signal in order for the machine to interpret it as a true signal :thinking:

The length of the continuous signal required depends on the quality of the button, I think :relieved:

P.S. There can be other ways than the continuous signal to filter these. It’s just one example :thinking:

Hey! Could you please try this out on beta 5.2.0 and let us know if this got better for you? MIDI behavior was changed a lot and has been reported to be behaving much better

Let us know, thanks!

Read more about it here:

Hi Brennan - I’d love to do that. One important question though:

Is there a way to regress to the current production version should I run into an issue for which there’s no workaround?

I should note that after some dedicated testing (with the current production version), I was not able to reproduce the problem when not busy actually playing music. It’s possible that I was sometimes accidentally hitting two buttons at once (with the buttons responding to the slightest amount of pressure, which is a good thing). So the last few days I’ve been more careful and haven’t had the problem so far (but more time is needed to know for sure, since it didn’t happen all that often).

Thanks, - Slim

Well, tonight (of course) I bumped into the problem again, this time I was definitely not hitting two buttons at once and the unit simply didn’t respond on a button press. So yes, anxious to see if the beta fixes this.

1 Like

The Aeros can be upgraded and downgraded easily to and from the current version if your Aeros is already on version 5.0.0 or later. If you are still on version 4.x.x or earlier, this is not as easy.

Let me know if it’s the latter and I can walk you through the steps.

All Aeros versions can be found here:

Great, will do (I’m currently on 5.1.1). Thanks.

I’m having same issue.

I’ve installed the Aeros beta and was happy to see that the features I rely on were all still working. However, the two issues I’ve reported (one in another thread) are still present:

  1. Seemingly random and only occasional button presses with no response: This happened again shortly after installing the 5.2 beta. For reference, here’s my MM configuration:

Page 1
Stop: CC 1 43 0 [stop song]
Clear: CC 1 42 0 [clear song immediately]
Mute: CC 1 20 0 [set master fader to zero]
Unmute: CC 1 20 113 [set master fader to 0dbFS]
Part 1: CC 1 113 101 [change to part 1, or record part 1 if empty]
Part 2: CC 1 113 102 [change to part 2, or record part 2 if empty]
Part 3: CC 1 113 103 [change to part 3, or record part 3 if empty]
Page 2
Switch To Beat Buddy sync: CC 1 0 0, PC 1 1 [Select Bank 0, Song 1]
Switch To Freeform: CC 1 0 0, PC 1 0 [Select Bank 0, Song 2]

The latest failure (which is not easy to reproduce, seems totally random) happened when sync’d to the BB clock and after having recorded a track on part one was finishing recording a track on part 2 then, pressing the Part 1 button to begin playback of part 1(nothing happened, continued to record on part 2).

In the past, this same scenario has occasionally happened when not syncing to the BB clock.

  1. Also, I heard a loud click coming out of the speaker during recording when switching from part 1 to part 2 using the MM. This click was not present on playback, only during recording. I’ve experienced this multiple times in the past as well, but this too seems to be totally random and difficult to reproduce on demand.

So, so far I haven’t discovered any new bugs, but the old ones haven’t been fixed by this update.


  • Slim

Thanks, fixed that typo.

1 Like

Is it possible for you to record the button presses using the Bluetooth connection of your MM? This way if the message is missing both in recording and Aeros you can be sure it’s MM. But if the message is not missing in recording then I’d turn to the Aeros to try to get the bug fixed :thinking:

I don’t remember anymore, but I assume you have made sure the cables are not the cause :relieved: So either MM or Aeros :sweat_smile:

Personally I could do such recording using MobileSheets app on my iPad :blush:

Funny you should mention that! This morning I hooked up a midi thru box to the output of the MM in order to monitor the midi stream on my computer while the MM is sending commands to the Aeros. But it may take a while to catch it in the act – will keep you posted as to what I find the next time this happens.

1 Like

Well, this is interesting. Yesterday during rehearsal I had a MIDI monitor running in parallel with the feed from the MM. The problem happened twice where the Aeros did not respond to my MM button press. Each time I checked the MIDI feed right after having pressed the button and the feed does show the button press. That would seem to put the blame squarely on the Aeros, no? (I’ve already ruled out the MIDI cable as being the culprit).

Now the big question is that is it a bug in every Aeros unit or is it just your unit :thinking::face_with_peeking_eye:

I mean that the midi port itself could be malfunctioning or some some wiring problem or something in this specific unit or then it could be related to the firmware version etc :sweat_smile:

But I guess now it’s it would be good to move this thread to the Aeros and not maestro :thinking:

So, as a follow-up experiment, since the Aeros has a MIDI thru option when operating as a receiver, I also monitored that stream along side the MIDI stream coming out of the MM. This clearly showed that the commands that the Aeros is not responding to are still in the MIDI stream at the Aeros output. So not likely a hardware issue, it just seems to be randomly ignoring commands. Seeing as I’ve learned a lot since starting this thread, I’ll start a new one in the Aeros section with a more concise summary of the situation. (Thanks aapo for your suggestions!)

Please do not start a new thread, keep it all here